Vulnerability · Published Jul 10, 2025 · Assigned by apache

CVE-2025-49812Apache HTTP Server: mod_ssl TLS upgrade attack

High 7.4

In plain English

A high-severity improper authentication in Apache HTTP Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.4High
Exploit odds (30 days)0.6%top 50.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade. Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8httpd2.4.37-65.module_el8.10.0+4044+ea5f78b1.5ALSA-2025:15123
AlmaLinux:9httpd2.4.62-4.el9_6.4ALSA-2025:15023
AlmaLinux:9httpd-core2.4.62-4.el9_6.4ALSA-2025:15023
AlmaLinux:8httpd-devel2.4.37-65.module_el8.10.0+4044+ea5f78b1.5ALSA-2025:15123
AlmaLinux:9httpd-devel2.4.62-4.el9_6.4ALSA-2025:15023
AlmaLinux:10httpd-filesystem2.4.63-1.el10_0.2ALSA-2025:15095
AlmaLinux:8httpd-filesystem2.4.37-65.module_el8.10.0+4044+ea5f78b1.5ALSA-2025:15123
AlmaLinux:9httpd-filesystem2.4.62-4.el9_6.4ALSA-2025:15023
AlmaLinux:10httpd-manual2.4.63-1.el10_0.2ALSA-2025:15095
AlmaLinux:8httpd-manual2.4.37-65.module_el8.10.0+4044+ea5f78b1.5ALSA-2025:15123
AlmaLinux:9httpd-manual2.4.62-4.el9_6.4ALSA-2025:15023
AlmaLinux:8httpd-tools2.4.37-65.module_el8.10.0+4044+ea5f78b1.5ALSA-2025:15123
AlmaLinux:9httpd-tools2.4.62-4.el9_6.4ALSA-2025:15023
AlmaLinux:8mod_http21.15.7-10.module_el8.10.0+4044+ea5f78b1.4ALSA-2025:15123
AlmaLinux:8mod_ldap2.4.37-65.module_el8.10.0+4044+ea5f78b1.5ALSA-2025:15123
AlmaLinux:9mod_ldap2.4.62-4.el9_6.4ALSA-2025:15023
AlmaLinux:9mod_lua2.4.62-4.el9_6.4ALSA-2025:15023
AlmaLinux:8mod_md1:2.0.8-8.module_el8.6.0+2872+fe0ff7aaALSA-2025:15123
AlmaLinux:8mod_md1:2.0.8-8.module_el8.6.0+3031+fb177b09ALSA-2025:15123
AlmaLinux:8mod_proxy_html1:2.4.37-65.module_el8.10.0+4044+ea5f78b1.5ALSA-2025:15123
AlmaLinux:9mod_proxy_html1:2.4.62-4.el9_6.4ALSA-2025:15023
AlmaLinux:8mod_session2.4.37-65.module_el8.10.0+4044+ea5f78b1.5ALSA-2025:15123
AlmaLinux:9mod_session2.4.62-4.el9_6.4ALSA-2025:15023
AlmaLinux:8mod_ssl1:2.4.37-65.module_el8.10.0+4044+ea5f78b1.5ALSA-2025:15123
AlmaLinux:9mod_ssl1:2.4.62-4.el9_6.4ALSA-2025:15023
Alpine:v3.20apache22.4.64-r0ALPINE-CVE-2025-49812
Alpine:v3.21apache22.4.64-r0ALPINE-CVE-2025-49812
Alpine:v3.22apache22.4.64-r0ALPINE-CVE-2025-49812
Alpine:v3.23apache22.4.64-r0ALPINE-CVE-2025-49812
Alpine:v3.24apache22.4.64-r0ALPINE-CVE-2025-49812
Debian:12apache22.4.65-1~deb12u1DEBIAN-CVE-2025-49812
Debian:13apache22.4.64-1DEBIAN-CVE-2025-49812
Debian:14apache22.4.64-1DEBIAN-CVE-2025-49812
Rocky Linux:10httpd0:2.4.63-1.el10_0.2RLSA-2025:15095
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1842+4a9649e8.2RLSA-2025:15123
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1830+22f0c9e0RLSA-2025:15123
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1984+1bed3124.4RLSA-2025:15123
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1938+3b7755d4.3RLSA-2025:15123
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1840+b070a976.1RLSA-2025:15123
Rocky Linux:9httpd0:2.4.62-4.el9_6.4RLSA-2025:15023
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1938+3b7755d4.3RLSA-2025:15123
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1830+22f0c9e0RLSA-2025:15123
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1775+6b057638RLSA-2025:15123
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1883+38ed6c58.1RLSA-2025:15123
Rocky Linux:8mod_md1:2.0.8-8.module+el8.9.0+1370+89cc8ad5RLSA-2025:15123
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.15USN-7639-1
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.15UBUNTU-CVE-2025-49812
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.7USN-7639-1
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.7UBUNTU-CVE-2025-49812

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache HTTP Server 0 – through 2.4.63

Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

References