Vulnerability · Published Jun 19, 2025 · Assigned by apache
CVE-2025-49763Apache Traffic Server: Remote DoS via memory exhaustion in ESI Plugin
High 7.5
In plain English
A high-severity uncontrolled resource consumption in Apache Traffic Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
ESI plugin does not have the limit for maximum inclusion depth, and that allows excessive memory consumption if malicious instructions are inserted. Users can use a new setting for the plugin (--max-inclusion-depth) to limit it. This issue affects Apache Traffic Server: from 10.0.0 through 10.0.5, from 9.0.0 through 9.2.10. Users are recommended to upgrade to version 9.2.11 or 10.0.6, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | trafficserver | 9.2.5+ds-0+deb12u3 | DEBIAN-CVE-2025-49763 |
| Debian:12 | trafficserver | 9.2.5+ds-0+deb12u3 | DSA-5948-1 |
| Ubuntu:24.04:LTS | trafficserver | no fix listed | UBUNTU-CVE-2025-49763 |
| Ubuntu:25.10 | trafficserver | no fix listed | UBUNTU-CVE-2025-49763 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Traffic Server | 10.0.0 – through 10.0.59.0.0 – through 9.2.10 |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://lists.apache.org/thread/15t32nxbypqg1m2smp640vjx89o6v5f8 vendor-advisory