Vulnerability · Published Jun 13, 2025 · Assigned by GitHub_M
CVE-2025-49598conda-forge-ci-setup Allows Arbitrary Code Execution via Insecure Version Parsing
Medium 4.4
In plain English
A medium-severity security flaw in conda-forge-ci-setup-feedstock from conda-forge. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 8% of all known vulnerabilities).
Official description
conda-forge-ci-setup is a package installed by conda-forge each time a build is run on CI. The conda-forge-ci-setup-feedstock setup script is vulnerable due to the unsafe use of the eval function when parsing version information from a custom-formatted meta.yaml file. An attacker controlling meta.yaml can inject malicious code into the version assignment, which is executed during file processing, leading to arbitrary code execution. Exploitation requires an attacker to modify the recipe file by manipulating the RECIPE_DIR variable and introducing a malicious meta.yaml file. While this is more feasible in CI/CD pipelines, it is uncommon in typical environments, reducing overall risk. This vulnerability is fixed in 4.15.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| conda-forge | conda-forge-ci-setup-feedstock | < 4.15.0 |
Weakness: CWE-95 · Vector: CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U