Vulnerability · Published Jun 18, 2025 · Assigned by GitHub_M
CVE-2025-49590CryptPad Dom-Based Cross-Site Scripting (XSS) Vulnerability
Low 2.9
In plain English
A low-severity security flaw in cryptpad from cryptpad. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities).
Official description
CryptPad is a collaboration suite. Prior to version 2025.3.0, the "Link Bouncer" functionality attempts to filter javascript URIs to prevent Cross-Site Scripting (XSS), however this can be bypassed. There is an "early allow" code path that happens before the URI's protocol/scheme is checked, which a maliciously crafted URI can follow. This issue has been patched in version 2025.3.0.
Affected products (as reported)
Weakness: CWE-692 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N/E:P
References
- https://github.com/cryptpad/cryptpad/security/advisories/GHSA-vq9h-x3gr-v8rj x_refsource_CONFIRM
- https://github.com/cryptpad/cryptpad/commit/d5e4830ba104a4a442cb23aab5378b8565a95607 x_refsource_MISC
- https://github.com/cryptpad/cryptpad/blob/15c81aa8ccb737a9a1167481f4a699af331364bb/www/bounce/main.js#L64-L95 x_refsource_MISC