Vulnerability · Published Aug 6, 2026 · Assigned by apache
CVE-2025-49506Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack
High 7.5
In plain English
A high-severity security flaw in Apache Portable Runtime Utility from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as Windows, BeOS, NetWare, or Android. Users are recommended to upgrade to version 1.6.4, which fixes this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | apr-util | 1.6.3-23.el10_2.1 | ALSA-2026:66392 |
| AlmaLinux:8 | apr-util | 1.6.1-9.el8_10.1 | ALSA-2026:69113 |
| AlmaLinux:9 | apr-util | 1.6.1-23.el9_8.1 | ALSA-2026:66341 |
| AlmaLinux:8 | apr-util-bdb | 1.6.1-9.el8_10.1 | ALSA-2026:69113 |
| AlmaLinux:9 | apr-util-bdb | 1.6.1-23.el9_8.1 | ALSA-2026:66341 |
| AlmaLinux:10 | apr-util-devel | 1.6.3-23.el10_2.1 | ALSA-2026:66392 |
| AlmaLinux:8 | apr-util-devel | 1.6.1-9.el8_10.1 | ALSA-2026:69113 |
| AlmaLinux:9 | apr-util-devel | 1.6.1-23.el9_8.1 | ALSA-2026:66341 |
| AlmaLinux:10 | apr-util-ldap | 1.6.3-23.el10_2.1 | ALSA-2026:66392 |
| AlmaLinux:8 | apr-util-ldap | 1.6.1-9.el8_10.1 | ALSA-2026:69113 |
| AlmaLinux:9 | apr-util-ldap | 1.6.1-23.el9_8.1 | ALSA-2026:66341 |
| AlmaLinux:10 | apr-util-lmdb | 1.6.3-23.el10_2.1 | ALSA-2026:66392 |
| AlmaLinux:10 | apr-util-mysql | 1.6.3-23.el10_2.1 | ALSA-2026:66392 |
| AlmaLinux:8 | apr-util-mysql | 1.6.1-9.el8_10.1 | ALSA-2026:69113 |
| AlmaLinux:9 | apr-util-mysql | 1.6.1-23.el9_8.1 | ALSA-2026:66341 |
| AlmaLinux:10 | apr-util-odbc | 1.6.3-23.el10_2.1 | ALSA-2026:66392 |
| AlmaLinux:8 | apr-util-odbc | 1.6.1-9.el8_10.1 | ALSA-2026:69113 |
| AlmaLinux:9 | apr-util-odbc | 1.6.1-23.el9_8.1 | ALSA-2026:66341 |
| AlmaLinux:10 | apr-util-openssl | 1.6.3-23.el10_2.1 | ALSA-2026:66392 |
| AlmaLinux:8 | apr-util-openssl | 1.6.1-9.el8_10.1 | ALSA-2026:69113 |
| AlmaLinux:9 | apr-util-openssl | 1.6.1-23.el9_8.1 | ALSA-2026:66341 |
| AlmaLinux:10 | apr-util-pgsql | 1.6.3-23.el10_2.1 | ALSA-2026:66392 |
| AlmaLinux:8 | apr-util-pgsql | 1.6.1-9.el8_10.1 | ALSA-2026:69113 |
| AlmaLinux:9 | apr-util-pgsql | 1.6.1-23.el9_8.1 | ALSA-2026:66341 |
| AlmaLinux:10 | apr-util-sqlite | 1.6.3-23.el10_2.1 | ALSA-2026:66392 |
| AlmaLinux:8 | apr-util-sqlite | 1.6.1-9.el8_10.1 | ALSA-2026:69113 |
| AlmaLinux:9 | apr-util-sqlite | 1.6.1-23.el9_8.1 | ALSA-2026:66341 |
| Alpine:v3.21 | apr-util | 1.6.4-r0 | ALPINE-CVE-2025-49506 |
| Alpine:v3.22 | apr-util | 1.6.4-r0 | ALPINE-CVE-2025-49506 |
| Alpine:v3.23 | apr-util | 1.6.4-r0 | ALPINE-CVE-2025-49506 |
| Alpine:v3.24 | apr-util | 1.6.4-r0 | ALPINE-CVE-2025-49506 |
| Debian:12 | apr-util | 1.6.3-1+deb12u1 | DEBIAN-CVE-2025-49506 |
| Debian:13 | apr-util | 1.6.3-3+deb13u1 | DEBIAN-CVE-2025-49506 |
| Debian:14 | apr-util | 1.6.4-1 | DEBIAN-CVE-2025-49506 |
| Rocky Linux:10 | apr-util | 0:1.6.3-23.el10_2.1 | RLSA-2026:66392 |
| Rocky Linux:8 | apr-util | 0:1.6.1-9.el8_10.1 | RLSA-2026:69113 |
| Rocky Linux:9 | apr-util | 0:1.6.1-23.el9_8.1 | RLSA-2026:66341 |
| Ubuntu:22.04:LTS | apr-util | 1.6.1-5ubuntu4.22.04.3 | USN-8719-1 |
| Ubuntu:22.04:LTS | apr-util | 1.6.1-5ubuntu4.22.04.3 | UBUNTU-CVE-2025-49506 |
| Ubuntu:24.04:LTS | apr-util | 1.6.3-1.1ubuntu7.1 | USN-8719-1 |
| Ubuntu:24.04:LTS | apr-util | 1.6.3-1.1ubuntu7.1 | UBUNTU-CVE-2025-49506 |
| Ubuntu:26.04:LTS | apr-util | 1.6.3-3ubuntu3.1 | UBUNTU-CVE-2025-49506 |
| Ubuntu:26.04:LTS | apr-util | 1.6.3-3ubuntu3.1 | USN-8719-1 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Portable Runtime Utility | 1.2.0 – through 1.6.3 |
Weakness: CWE-208 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N