Vulnerability · Published Jun 11, 2025 · Assigned by HashiCorp
CVE-2025-4922Nomad Vulnerable To Incorrect ACL Policy Lookup Attached To A Job
High 8.1
In plain English
A high-severity security flaw in Nomad from HashiCorp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.5%top 56.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Nomad Community and Nomad Enterprise (“Nomad”) prefix-based ACL policy lookup can lead to incorrect rule application and shadowing. This vulnerability, identified as CVE-2025-4922, is fixed in Nomad Community Edition 1.10.2 and Nomad Enterprise 1.10.2, 1.9.10, and 1.8.14.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/hashicorp/nomad | 1.10.2 | GHSA-rx97-6c62-55mf |
| Go | github.com/hashicorp/nomad | 1.10.2 | GO-2025-3758 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| HashiCorp | Nomad | 1.4.0 – before 1.10.2 |
| HashiCorp | Nomad Enterprise | 1.4.0 – before 1.10.2 |
Weakness: CWE-266 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N