Vulnerability · Published Jun 20, 2025 · Assigned by GitHub_M
CVE-2025-49132Pterodactyl Panel Allows Unauthenticated Arbitrary Remote Code Execution
Critical 10.0
In plain English
A critical-severity code injection in panel from pterodactyl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 54.5% (higher than 99.0% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Pterodactyl is a free, open-source game server management panel. Prior to version 1.11.11, using the /locales/locale.json with the locale and namespace query parameters, a malicious actor is able to execute arbitrary code without being authenticated. With the ability to execute arbitrary code it could be used to gain access to the Panel's server, read credentials from the Panel's config, extract sensitive information from the database, access files of servers managed by the panel, etc. This issue has been patched in version 1.11.11. There are no software workarounds for this vulnerability, but use of an external Web Application Firewall (WAF) could help mitigate this attack.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | pterodactyl/panel | 1.11.11 | GHSA-24wv-6c99-f843 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| pterodactyl | panel | < 1.11.11 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H