Vulnerability · Published Jun 23, 2025 · Assigned by GitHub_M
CVE-2025-49126Visionatrix Vulnerable to Reflected XSS Leading to Exfiltration of Secrets
High 8.8
In plain English
A high-severity cross-site scripting in Visionatrix from Visionatrix. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities).
Official description
Visionatrix is an AI Media processing tool using ComfyUI. In versions 1.5.0 to before 2.5.1, the /docs/flows endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack allowing full takeover of the application and exfiltration of secrets stored in the application. The implementation uses the get_swagger_ui_html function from FastAPI. This function does not encode or sanitize its arguments before using them to generate the HTML for the swagger documentation page and is not intended to be used with user-controlled arguments. Any user of this application can be targeted with a one-click attack that can takeover their session and all the secrets that may be contained within it. This issue has been patched in version 2.5.1.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Visionatrix | Visionatrix | >= 1.5.0, < 2.5.1 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:L