Vulnerability · Published Nov 7, 2025 · Assigned by hackerone

CVE-2025-48985

Low 3.7

In plain English

A low-severity improper input validation in AI SDK from Vercel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)0.3%top 79.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A vulnerability in Vercel’s AI SDK has been fixed in versions 5.0.52, 5.1.0-beta.9, and 6.0.0-beta. This issue may have allowed users to bypass filetype whitelists when uploading files. All users are encouraged to upgrade. More details: https://vercel.com/changelog/cve-2025-48985-input-validation-bypass-on-ai-sdk

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmai5.0.52GHSA-rwvc-j5jr-mgvh
npmai5.1.0-beta.9GHSA-rwvc-j5jr-mgvh

Affected products (as reported)

VendorProductVersions
Vercel AI SDK 5.0.51 – through 5.0.515.1.0-beta.8 – through 5.1.0-beta.8

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

References