Vulnerability · Published Aug 21, 2025 · Assigned by GitHub_M
CVE-2025-48956vLLM API endpoints vulnerable to Denial of Service Attacks
High 7.5
In plain English
A high-severity uncontrolled resource consumption in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | vllm | 0.10.1.1 | GHSA-rxc4-3w6r-4v47 |
| PyPI | vllm | 0.10.1.1 | PYSEC-2026-2021 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| vllm-project | vllm | >= 0.1.0, < 0.10.1.1 |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-rxc4-3w6r-4v47 x_refsource_CONFIRM
- https://github.com/vllm-project/vllm/pull/23267 x_refsource_MISC
- https://github.com/vllm-project/vllm/commit/d8b736f913a59117803d6701521d2e4861701944 x_refsource_MISC