Vulnerability · Published Aug 8, 2025 · Assigned by apache
CVE-2025-48913Apache CXF: Untrusted JMS configuration can lead to RCE
Critical 9.8
In plain English
A critical-severity improper input validation in Apache CXF from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
If untrusted users are allowed to configure JMS for Apache CXF, previously they could use RMI or LDAP URLs, potentially leading to code execution capabilities. This interface is now restricted to reject those protocols, removing this possibility. Users are recommended to upgrade to versions 3.6.8, 4.0.9 or 4.1.3, which fix this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.cxf:cxf-rt-transports-jms | 3.6.8 | GHSA-g4px-6qhm-hqjm |
| Maven | org.apache.cxf:cxf-rt-transports-jms | 4.0.9 | GHSA-g4px-6qhm-hqjm |
| Maven | org.apache.cxf:cxf-rt-transports-jms | 4.1.3 | GHSA-g4px-6qhm-hqjm |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache CXF | 4.1.0 – before 4.1.34.0.0 – before 4.0.90 – before 3.6.8 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H