Vulnerability · Published May 30, 2025 · Assigned by GitHub_M

CVE-2025-48883Chrome PHP is missing encoding in `CssSelector`

Medium 5.3

In plain English

A medium-severity cross-site scripting in chrome from chrome-php. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.5%top 59.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Chrome PHP allows users to start playing with chrome/chromium in headless mode from PHP. Prior to version 1.14.0, CSS Selector expressions are not properly encoded, which can lead to XSS (cross-site scripting) vulnerabilities. This is patched in v1.14.0. As a workaround, users can apply encoding manually to their selectors if they are unable to upgrade.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistchrome-php/chrome1.14.0GHSA-3432-fmrf-7vmh

Affected products (as reported)

VendorProductVersions
chrome-php chrome < 1.14.0

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

References