Vulnerability · Published May 30, 2025 · Assigned by GitHub_M
CVE-2025-48881Valtimo backend libraries allows objects in the object-api to be accessed and modified by unauthorized users
High 8.3
In plain English
A high-severity incorrect authorization in valtimo-backend-libraries from valtimo-platform. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Valtimo is a platform for Business Process Automation. In versions starting from 11.0.0.RELEASE to 11.3.3.RELEASE and 12.0.0.RELEASE to 12.12.0.RELEASE, all objects for which an object-management configuration exists can be listed, viewed, edited, created or deleted by unauthorised users. If object-urls are exposed via other channels, the contents of these objects can be viewed independent of object-management configurations. This issue has been patched in version 12.13.0.RELEASE. A workaround for this issue involves overriding the endpoint security as defined in ObjectenApiHttpSecurityConfigurer and ObjectManagementHttpSecurityConfigurer. Depending on the implementation, this could result in loss of functionality.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | com.ritense.valtimo:object-management | no fix listed | GHSA-965r-9cg9-g42p |
| Maven | com.ritense.valtimo:object-management | 12.13.0.RELEASE | GHSA-965r-9cg9-g42p |
| Maven | com.ritense.valtimo:objecten-api | no fix listed | GHSA-965r-9cg9-g42p |
| Maven | com.ritense.valtimo:objecten-api | 12.13.0.RELEASE | GHSA-965r-9cg9-g42p |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| valtimo-platform | valtimo-backend-libraries | >= 11.0.0.RELEASE, <= 11.3.3.RELEASE>= 12.0.0.RELEASE, < 12.13.0.RELEASE |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L