Vulnerability · Published May 30, 2025 · Assigned by GitHub_M

CVE-2025-48492GetSimple CMS RCE in Edit component

High 8.6

In plain English

A high-severity command injection in GetSimpleCMS-CE from GetSimpleCMS-CE. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities).

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)1.0%top 37.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

GetSimple CMS is a content management system. In versions starting from 3.3.16 to 3.3.21, an authenticated user with access to the Edit component can inject arbitrary PHP into a component file and execute it via a crafted query string, resulting in Remote Code Execution (RCE). This issue is set to be patched in version 3.3.22.

Affected products (as reported)

VendorProductVersions
GetSimpleCMS-CE GetSimpleCMS-CE >= 3.3.16, <= 3.3.21

Weakness: CWE-77 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References