Vulnerability · Published May 27, 2025 · Assigned by GitHub_M
CVE-2025-48383Django-Select2 Vulnerable to Widget Instance Secret Cache Key Leaking
High 8.2
In plain English
A high-severity server-side request forgery in django-select2 from codingjoe. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Django-Select2 is a Django integration for Select2. Prior to version 8.4.1, instances of HeavySelect2Mixin subclasses like the ModelSelect2MultipleWidget and ModelSelect2Widget can leak secret access tokens across requests. This can allow users to access restricted query sets and restricted data. This issue has been patched in version 8.4.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | django-select2 | 7.10.0-2 | DEBIAN-CVE-2025-48383 |
| Debian:14 | django-select2 | 7.10.0-2 | DEBIAN-CVE-2025-48383 |
| PyPI | django-select2 | 8.4.1 | GHSA-wjrh-hj83-3wh7 |
| PyPI | django-select2 | 8.4.1 | PYSEC-2026-1300 |
| Ubuntu:22.04:LTS | django-select2 | no fix listed | UBUNTU-CVE-2025-48383 |
| Ubuntu:24.04:LTS | django-select2 | no fix listed | UBUNTU-CVE-2025-48383 |
| Ubuntu:25.10 | django-select2 | no fix listed | UBUNTU-CVE-2025-48383 |
| Ubuntu:26.04:LTS | django-select2 | no fix listed | UBUNTU-CVE-2025-48383 |
| Ubuntu:26.10 | django-select2 | no fix listed | UBUNTU-CVE-2025-48383 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| codingjoe | django-select2 | < 8.4.1 |
Weakness: CWE-402, CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N