Vulnerability · Published May 30, 2025 · Assigned by GitHub_M
CVE-2025-48068Information exposure in Next.js dev server due to lack of origin verification
Low 2.3
In plain English
A low-severity security flaw in next.js from vercel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Next.js is a React framework for building full-stack web applications. In versions starting from 13.0 to before 14.2.30 and 15.0.0 to before 15.2.2, Next.js may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active. This issue has been patched in versions 14.2.30 and 15.2.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | next | 15.2.2 | GHSA-3h52-269p-cp9r |
| npm | next | 14.2.30 | GHSA-3h52-269p-cp9r |
Affected products (as reported)
Weakness: CWE-1385 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N
References
- https://github.com/vercel/next.js/security/advisories/GHSA-3h52-269p-cp9r x_refsource_CONFIRM
- https://vercel.com/changelog/cve-2025-48068 x_refsource_MISC