Vulnerability · Published Jun 20, 2025 · Assigned by GitHub_M
CVE-2025-48059PowSyBl Core Contains a Polynomial ReDoS in RegexCriterion
Low 2.7
In plain English
A low-severity regular-expression denial of service in powsybl-core from powsybl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
PowSyBl (Power System Blocks) is a framework to build power system oriented software. In com.powsybl:powsybl-iidm-criteria versions 6.3.0 to before 6.7.2 and com.powsybl:powsybl-contingency-api versions 5.0.0 to before 6.3.0, there is a a potential polynomial Regular Expression Denial of Service (ReDoS) vulnerability in the RegexCriterion class. This class compiles and evaluates an unvalidated, user-supplied regular expression against the identifier of an Identifiable object via Pattern.compile(regex).matcher(id).find(). If successfully exploited, a malicious actor can cause significant CPU exhaustion through repeated or recursive filter(...) calls — especially if performed over large network models or filtering operations. This issue has been patched in com.powsybl:powsybl-iidm-criteria 6.7.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | com.powsybl:powsybl-contingency-api | 6.3.0 | GHSA-8qjw-9xgm-c9ff |
| Maven | com.powsybl:powsybl-iidm-criteria | 6.7.2 | GHSA-8qjw-9xgm-c9ff |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| powsybl | powsybl-core | >= 6.3.0, < 6.7.2>= 5.0.0, < 6.3.0 |
Weakness: CWE-1333 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U