Vulnerability · Published Jun 20, 2025 · Assigned by GitHub_M

CVE-2025-48058PowSyBl Core contains Polynomial REDoS’es

Medium 6.3

In plain English

A medium-severity regular-expression denial of service in powsybl-core from powsybl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.3Medium
Exploit odds (30 days)0.4%top 63.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

PowSyBl (Power System Blocks) is a framework to build power system oriented software. Prior to version 6.7.2, there is a potential polynomial Regular Expression Denial of Service (ReDoS) vulnerability in the PowSyBl's DataSource mechanism. If successfully exploited, a malicious actor can cause significant CPU consumption due to regex backtracking — even with polynomial patterns. This issue has been patched in com.powsybl:powsybl-commons: 6.7.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavencom.powsybl:powsybl-commons6.7.2GHSA-rqpx-f6rc-7hm5

Affected products (as reported)

VendorProductVersions
powsybl powsybl-core < 6.7.2

Weakness: CWE-1333 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

References