Vulnerability · Published May 19, 2025 · Assigned by GitHub_M
CVE-2025-47944Multer vulnerable to Denial of Service from maliciously crafted requests
High 7.5
In plain English
A high-severity security flaw in multer from expressjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | multer | 2.0.0 | GHSA-4pg4-qvpc-4q3h |
Affected products (as reported)
Weakness: CWE-248 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/expressjs/multer/security/advisories/GHSA-4pg4-qvpc-4q3h x_refsource_CONFIRM
- https://github.com/expressjs/multer/issues/1176 x_refsource_MISC
- https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665 x_refsource_MISC