Vulnerability · Published Jun 24, 2025 · Assigned by GitHub_M

CVE-2025-47943Gogs stored XSS in PDF renderer

Medium 6.3

In plain English

A medium-severity cross-site scripting in gogs from gogs. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)0.4%top 66.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Gogs is an open source self-hosted Git service. In application version 0.14.0+dev and prior, there is a stored cross-site scripting (XSS) vulnerability present in Gogs, which allows client-side Javascript code execution. The vulnerability is caused by the usage of a vulnerable and outdated component: pdfjs-1.4.20 under public/plugins/. This issue has been fixed for gogs.io/gogs in version 0.13.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/gogs/gogs0.13.3-0.20250608224432-110117b2e5e5GHSA-xh32-cx6c-cp4v
Gogogs.io/gogs0.13.3-0.20250608224432-110117b2e5e5GHSA-xh32-cx6c-cp4v
Gogogs.io/gogs0.13.3-0.20250608224432-110117b2e5e5GO-2025-3778

Affected products (as reported)

VendorProductVersions
gogs gogs <= 0.14.0+dev

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N

References