Vulnerability · Published May 20, 2025 · Assigned by GitHub_M
CVE-2025-47940TYPO3 CMS Vulnerable to Privilege Escalation to System Maintainer
High 7.2
In plain English
A high-severity security flaw in typo3 from TYPO3. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
TYPO3 is an open source, PHP based web content management system. Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. Users should update to TYPO3 version 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | typo3/cms-core | 10.4.50 | GHSA-6frx-j292-c844 |
| Packagist | typo3/cms-core | 11.5.44 | GHSA-6frx-j292-c844 |
| Packagist | typo3/cms-core | 12.4.31 | GHSA-6frx-j292-c844 |
| Packagist | typo3/cms-core | 13.4.12 | GHSA-6frx-j292-c844 |
Affected products (as reported)
Weakness: CWE-283 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/TYPO3/typo3/security/advisories/GHSA-6frx-j292-c844 x_refsource_CONFIRM
- https://typo3.org/security/advisory/typo3-core-sa-2025-016 x_refsource_MISC