Vulnerability · Published May 20, 2025 · Assigned by GitHub_M

CVE-2025-47937TYPO3 Vulnerable to Information Disclosure via DBAL Restriction Handling

Low 3.7

In plain English

A low-severity incorrect authorization in typo3 from TYPO3. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)0.3%top 77.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

TYPO3 is an open source, PHP based web content management system. Starting in version 9.0.0 and prior to versions 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, when performing a database query involving multiple tables through the database abstraction layer (DBAL), frontend user permissions are only applied via `FrontendGroupRestriction` to the first table. As a result, data from additional tables included in the same query may be unintentionally exposed to unauthorized users. Users should update to TYPO3 version 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagisttypo3/cms-core9.5.51GHSA-x8pv-fgxp-8v3x
Packagisttypo3/cms-core10.4.50GHSA-x8pv-fgxp-8v3x
Packagisttypo3/cms-core11.5.44GHSA-x8pv-fgxp-8v3x
Packagisttypo3/cms-core12.4.31GHSA-x8pv-fgxp-8v3x
Packagisttypo3/cms-core13.4.12GHSA-x8pv-fgxp-8v3x

Affected products (as reported)

VendorProductVersions
TYPO3 typo3 >= 9.0.0, < 9.5.51>= 10.0.0, < 10.4.50>= 11.0.0, < 11.5.44>= 12.0.0, < 12.4.31>= 13.0.0, < 13.4.12

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

References