Vulnerability · Published May 20, 2025 · Assigned by GitHub_M

CVE-2025-47936TYPO3 Vulnerable to Server Side Request Forgery via Webhooks

Low 3.3

In plain English

A low-severity server-side request forgery in typo3 from TYPO3. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.3Low
Exploit odds (30 days)0.3%top 80.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

TYPO3 is an open source, PHP based web content management system. In versions on the 12.x branch prior to 12.4.31 LTS and the 13.x branch prior to 13.4.2 LTS, Webhooks are inherently vulnerable to Cross-Site Request Forgery (CSRF), which can be exploited by adversaries to target internal resources (e.g., localhost or other services on the local network). While this is not a vulnerability in TYPO3 itself, it may enable attackers to blindly access systems that would otherwise be inaccessible. An administrator-level backend user account is required to exploit this vulnerability. Users should update to TYPO3 version 12.4.31 LTS or 13.4.12 LTS to fix the problem.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagisttypo3/cms-webhooks12.4.31GHSA-p4xx-m758-3hpx
Packagisttypo3/cms-webhooks13.4.12GHSA-p4xx-m758-3hpx

Affected products (as reported)

VendorProductVersions
TYPO3 typo3 >= 12.0.0, < 12.4.31>= 13.0.0, < 13.4.12

Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:L

References