Vulnerability · Published May 21, 2025 · Assigned by GitHub_M

CVE-2025-47291containerd CRI plugin: Incorrect cgroup hierarchy assignment for containers running in usernamespaced Kubernetes pods.

Medium 4.6

In plain English

A medium-severity security flaw in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)4.6Medium
Exploit odds (30 days)0.3%top 78.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

containerd is an open-source container runtime. A bug was found in the containerd's CRI implementation where containerd, starting in version 2.0.1 and prior to version 2.0.5, doesn't put usernamespaced containers under the Kubernetes' cgroup hierarchy, therefore some Kubernetes limits are not honored. This may cause a denial of service of the Kubernetes node. This bug has been fixed in containerd 2.0.5+ and 2.1.0+. Users should update to these versions to resolve the issue. As a workaround, disable usernamespaced pods in Kubernetes temporarily.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/containerd/containerd/v22.0.5GO-2025-3701
Gogithub.com/containerd/containerd/v22.0.5GHSA-cxfp-7pvr-95ff
Ubuntu:25.10containerd-app2.0.5-0ubuntu1UBUNTU-CVE-2025-47291

Affected products (as reported)

VendorProductVersions
containerd containerd >= 2.0.1, < 2.0.5

Weakness: CWE-266 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U

References