Vulnerability · Published May 15, 2025 · Assigned by GitHub_M

CVE-2025-47287Tornado vulnerable to excessive logging caused by malformed multipart form data

High 7.5

In plain English

A high-severity resource allocation without limits in tornado from tornadoweb. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.7%top 45.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Tornado is a Python web framework and asynchronous networking library. When Tornado's ``multipart/form-data`` parser encounters certain errors, it logs a warning but continues trying to parse the remainder of the data. This allows remote attackers to generate an extremely high volume of logs, constituting a DoS attack. This DoS is compounded by the fact that the logging subsystem is synchronous. All versions of Tornado prior to 6.5.0 are affected. The vulnerable parser is enabled by default. Upgrade to Tornado version 6.50 to receive a patch. As a workaround, risk can be mitigated by blocking `Content-Type: multipart/form-data` in a proxy.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8pcs0.10.18-2.el8_10.5.alma.1ALSA-2025:8254
AlmaLinux:8pcs-snmp0.10.18-2.el8_10.5.alma.1ALSA-2025:8254
AlmaLinux:10python3-tornado6.4.2-1.el10_0.1ALSA-2025:8135
AlmaLinux:9python3-tornado6.4.2-2.el9_6.2ALSA-2025:8136
Debian:12python-tornado6.2.0-3+deb12u2DEBIAN-CVE-2025-47287
Debian:12python-tornado6.2.0-3+deb12u2DSA-5938-1
Debian:13python-tornado6.4.2-2DEBIAN-CVE-2025-47287
Debian:14python-tornado6.4.2-2DEBIAN-CVE-2025-47287
PyPItornado6.5GHSA-7cx3-6m66-7c5m
PyPItornado6.5PYSEC-2026-1974
Rocky Linux:8pcs0:0.10.18-2.el8_10.5RLSA-2025:8254
Rocky Linux:10python-tornado0:6.4.2-1.el10_0.1RLSA-2025:8135
Rocky Linux:9python-tornado0:6.4.2-2.el9_6.2RLSA-2025:8136
Ubuntu:24.04:LTSpython-tornado6.4.0-1ubuntu0.2USN-7547-1
Ubuntu:24.04:LTSpython-tornado6.4.0-1ubuntu0.2UBUNTU-CVE-2025-47287
Ubuntu:25.10python-tornado6.4.2-2UBUNTU-CVE-2025-47287

Affected products (as reported)

VendorProductVersions
tornadoweb tornado < 6.5.0

Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References