Vulnerability · Published May 15, 2025 · Assigned by GitHub_M

CVE-2025-47279undici Denial of Service attack via bad certificate data

Low 3.1

In plain English

A low-severity memory leak in undici from nodejs. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.1Low
Exploit odds (30 days)0.3%top 72.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Undici is an HTTP/1.1 client for Node.js. Prior to versions 5.29.0, 6.21.2, and 7.5.0, applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak. This has been patched in versions 5.29.0, 6.21.2, and 7.5.0. As a workaound, avoid calling a webhook repeatedly if the webhook fails.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-undicino fix listedDEBIAN-CVE-2025-47279
Debian:13node-undicino fix listedDEBIAN-CVE-2025-47279
Debian:14node-undici7.24.5+dfsg+~cs3.2.0-1DEBIAN-CVE-2025-47279
Ubuntu:24.04:LTSnode-undicino fix listedUBUNTU-CVE-2025-47279
Ubuntu:25.10node-undicino fix listedUBUNTU-CVE-2025-47279
Ubuntu:26.04:LTSnode-undicino fix listedUBUNTU-CVE-2025-47279
Ubuntu:26.10node-undicino fix listedUBUNTU-CVE-2025-47279
npmundici7.5.0GHSA-cxrh-j4jr-qwg3
npmundici6.21.2GHSA-cxrh-j4jr-qwg3
npmundici5.29.0GHSA-cxrh-j4jr-qwg3

Affected products (as reported)

VendorProductVersions
nodejs undici < 5.29.0>= 6.0.0, < 6.21.2>= 7.0.0, < 7.5.0

Weakness: CWE-401 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L

References