Vulnerability · Published May 29, 2025 · Assigned by GitHub_M
CVE-2025-46823OpenMRS has Vulnerability in FHIR2 Module Privileges
High 8.0
In plain English
A high-severity missing authorization in openmrs-module-fhir2 from openmrs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities).
Official description
openmrs-module-fhir2 provides the FHIR REST API and related services for OpenMRS, an open medical records system. In versions of the FHIR2 module prior to 2.5.0, privileges were not always correctly checked, which means that unauthorized users may have been able to add or edit data they were not supposed to be able to. All implementers should update to FHIR2 2.5.0 or newer as soon as is feasible to receive a patch.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| openmrs | openmrs-module-fhir2 | < 2.5.0 |
Weakness: CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U