Vulnerability · Published May 5, 2025 · Assigned by GitHub_M

CVE-2025-46731Craft CMS Contains a Potential Remote Code Execution Vulnerability via Twig SSTI

High 7.3

In plain English

A high-severity security flaw in cms from craftcms. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 75% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.3High
Exploit odds (30 days)1.5%top 24.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling1Public PoC

Official description

Craft is a content management system. Versions of Craft CMS on the 4.x branch prior to 4.14.13 and on the 5.x branch prior to 5.6.16 contains a potential remote code execution vulnerability via Twig SSTI. One must have administrator access and `ALLOW_ADMIN_CHANGES` must be enabled for this to work. Users should update to the patched versions 4.14.13 or 5.6.15 to mitigate the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcraftcms/cms4.14.13GHSA-7c58-g782-9j38
Packagistcraftcms/cms5.6.15GHSA-7c58-g782-9j38

Affected products (as reported)

VendorProductVersions
craftcms cms >= 4.0.0-RC1, < 4.14.13>= 5.0.0-RC1, < 5.6.15

Weakness: CWE-1336 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P

References