Vulnerability · Published May 8, 2025 · Assigned by GitHub_M

CVE-2025-46712Erlang/OTP SSH Has Strict KEX Violations

Low 3.7

In plain English

A low-severity security flaw in otp from erlang. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)0.5%top 54.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Erlang/OTP is a set of libraries for the Erlang programming language. In versions prior to OTP-27.3.4 (for OTP-27), OTP-26.2.5.12 (for OTP-26), and OTP-25.3.2.21 (for OTP-25), Erlang/OTP SSH fails to enforce strict KEX handshake hardening measures by allowing optional messages to be exchanged. This allows a Man-in-the-Middle attacker to inject these messages in a connection during the handshake. This issue has been patched in versions OTP-27.3.4 (for OTP-27), OTP-26.2.5.12 (for OTP-26), and OTP-25.3.2.21 (for OTP-25).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.21erlang26.2.5.12-r0ALPINE-CVE-2025-46712
Debian:12erlang1:25.2.3+dfsg-1+deb12u2DEBIAN-CVE-2025-46712
Debian:13erlang1:27.3.4+dfsg-1DEBIAN-CVE-2025-46712
Debian:14erlang1:27.3.4+dfsg-1DEBIAN-CVE-2025-46712
Ubuntu:22.04:LTSerlang1:24.2.1+dfsg-1ubuntu0.5USN-7656-1
Ubuntu:22.04:LTSerlang1:24.2.1+dfsg-1ubuntu0.5UBUNTU-CVE-2025-46712
Ubuntu:24.04:LTSerlang1:25.3.2.8+dfsg-1ubuntu4.4UBUNTU-CVE-2025-46712
Ubuntu:24.04:LTSerlang1:25.3.2.8+dfsg-1ubuntu4.4USN-7656-1
Ubuntu:25.10erlang1:27.3.4.1+dfsg-1UBUNTU-CVE-2025-46712

Affected products (as reported)

VendorProductVersions
erlang otp >= OTP 27.0, < OTP 27.3.4>= OTP 26.2.1, < OTP 26.2.5.12< OTP 25.3.2.21

Weakness: CWE-440 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

References