Vulnerability · Published May 29, 2025 · Assigned by apache

CVE-2025-46701Apache Tomcat: Security constraint bypass for CGI scripts

High 7.3

In plain English

A high-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.1% (higher than 88% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)3.1%top 12.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-admin-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-docs-webapp1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-el-3.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-lib1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-webapps1:9.0.120-1.el8_10ALSA-2026:68677
Debian:12tomcat1010.1.52-1~deb12u1DEBIAN-CVE-2025-46701
Debian:12tomcat1010.1.52-1~deb12u1DSA-6120-1
Debian:13tomcat1010.1.52-1~deb13u1DSA-6120-1
Debian:13tomcat1010.1.52-1~deb13u1DEBIAN-CVE-2025-46701
Debian:14tomcat1010.1.46-1DEBIAN-CVE-2025-46701
Debian:13tomcat1111.0.15-1~deb13u1DSA-6121-1
Debian:13tomcat1111.0.15-1~deb13u1DEBIAN-CVE-2025-46701
Debian:14tomcat1111.0.11-1DEBIAN-CVE-2025-46701
Debian:12tomcat99.0.70-2DEBIAN-CVE-2025-46701
Debian:13tomcat99.0.70-2DEBIAN-CVE-2025-46701
Debian:14tomcat99.0.70-2DEBIAN-CVE-2025-46701
Mavenorg.apache.tomcat.embed:tomcat-embed-coreno fix listedGHSA-h2fw-rfh5-95r3
Mavenorg.apache.tomcat.embed:tomcat-embed-core11.0.7GHSA-h2fw-rfh5-95r3
Mavenorg.apache.tomcat.embed:tomcat-embed-core10.1.41GHSA-h2fw-rfh5-95r3
Mavenorg.apache.tomcat.embed:tomcat-embed-core9.0.105GHSA-h2fw-rfh5-95r3
Mavenorg.apache.tomcat:tomcat-catalinano fix listedGHSA-h2fw-rfh5-95r3
Mavenorg.apache.tomcat:tomcat-catalina9.0.105GHSA-h2fw-rfh5-95r3
Mavenorg.apache.tomcat:tomcat-catalina10.1.41GHSA-h2fw-rfh5-95r3
Mavenorg.apache.tomcat:tomcat-catalina11.0.7GHSA-h2fw-rfh5-95r3
Rocky Linux:10tomcat1:10.1.49-1.el10_2.1RLSA-2026:18537
Ubuntu:25.10tomcat11no fix listedUBUNTU-CVE-2025-46701
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2025-46701

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.610.1.0-M1 – through 10.1.409.0.0.M1 – through 9.0.1048.5.0 – through 8.5.100

Weakness: CWE-178 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

References