Vulnerability · Published Apr 30, 2025 · Assigned by GitHub_M
CVE-2025-46560vLLM phi4mm: Quadratic Time Complexity in Input Token Processing leads to denial of service
Medium 6.5
In plain English
A medium-severity regular-expression denial of service in vllm from vllm-project. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.8.0 and prior to 0.8.5 are affected by a critical performance vulnerability in the input preprocessing logic of the multimodal tokenizer. The code dynamically replaces placeholder tokens (e.g., <|audio_|>, <|image_|>) with repeated tokens based on precomputed lengths. Due to inefficient list concatenation operations, the algorithm exhibits quadratic time complexity (O(n²)), allowing malicious actors to trigger resource exhaustion via specially crafted inputs. This issue has been patched in version 0.8.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | vllm | 0.8.5 | GHSA-vc6m-hm49-g9qg |
| PyPI | vllm | 0.8.5 | PYSEC-2026-2022 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| vllm-project | vllm | >= 0.8.0, < 0.8.5 |
Weakness: CWE-1333 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H