Vulnerability · Published Apr 29, 2025 · Assigned by GitHub_M

CVE-2025-46549Yeswiki Vulnerable to Unauthenticated Reflected Cross-site Scripting

Medium 4.3

In plain English

A medium-severity cross-site scripting in yeswiki from YesWiki. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 46% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.6%top 53.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling1Nuclei

Official description

YesWiki is a wiki system written in PHP. Prior to version 4.5.4, an attacker can use a reflected cross-site scripting attack to steal cookies from an authenticated user by having them click on a malicious link. Stolen cookies allow the attacker to take over the user’s session. This vulnerability may also allow attackers to deface the website or embed malicious content. This issue has been patched in version 4.5.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistyeswiki/yeswiki4.5.4GHSA-r9gv-qffm-xw6f

Affected products (as reported)

VendorProductVersions
YesWiki yeswiki < 4.5.4

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

References