Vulnerability · Published Apr 29, 2025 · Assigned by GitHub_M
CVE-2025-46347YesWiki Remote Code Execution via Arbitrary PHP File Write and Execution
Medium 5.8
In plain English
A medium-severity security flaw in yeswiki from YesWiki. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
YesWiki is a wiki system written in PHP. Prior to version 4.5.4, YesWiki vulnerable to remote code execution. An arbitrary file write can be used to write a file with a PHP extension, which then can be browsed to in order to execute arbitrary code on the server, resulting in a full compromise of the server. This could potentially be performed unwittingly by a user. This issue has been patched in version 4.5.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | yeswiki/yeswiki | 4.5.4 | GHSA-88xg-v53p-fpvf |
Affected products (as reported)
Weakness: CWE-116 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/E:P