Vulnerability · Published Apr 29, 2025 · Assigned by GitHub_M
CVE-2025-46330Snowflake Connector for C/C++ retries malformed requests
Low 3.3
In plain English
A low-severity security flaw in libsnowflakeclient from snowflakedb. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities).
Severity (CVSS 3.1)3.3Low
Exploit odds (30 days)0.2%top 93.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
libsnowflakeclient is the Snowflake Connector for C/C++. Versions starting from 0.5.0 to before 2.2.0, incorrectly treat malformed requests that caused the HTTP response status code 400, as able to be retried. This could hang the application until SF_CON_MAX_RETRY requests were sent. This issue has been patched in version 2.2.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| snowflakedb | libsnowflakeclient | >= 0.5.0, < 2.2.0 |
Weakness: CWE-573 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L