Vulnerability · Published May 8, 2025 · Assigned by mitre
CVE-2025-44021
Low 2.8
In plain English
A low-severity path traversal in Ironic from OpenStack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenStack Ironic before 29.0.1 can write unintended files to a target node disk during image handling (if a deployment was performed via the API). A malicious project assigned as a node owner can provide a path to any local file (readable by ironic-conductor), which may then be written to the target node disk. This is difficult to exploit in practice, because a node deployed in this manner should never reach the ACTIVE state, but it still represents a danger in environments running with non-default, insecure configurations such as with automated cleaning disabled. The fixed versions are 24.1.3, 26.1.1, and 29.0.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | ironic | 1:21.1.0-3+deb12u1 | DEBIAN-CVE-2025-44021 |
| Debian:13 | ironic | 1:29.0.0-6 | DEBIAN-CVE-2025-44021 |
| Debian:14 | ironic | 1:29.0.0-6 | DEBIAN-CVE-2025-44021 |
| PyPI | ironic | 24.1.3, 26.1.1, 29.0.1 | PYSEC-2025-38 |
| PyPI | ironic | 24.1.3 | GHSA-q3m2-crgq-5p3q |
| PyPI | ironic | 26.1.1 | GHSA-q3m2-crgq-5p3q |
| PyPI | ironic | 29.0.1 | GHSA-q3m2-crgq-5p3q |
| Ubuntu:22.04:LTS | ironic | no fix listed | UBUNTU-CVE-2025-44021 |
| Ubuntu:24.04:LTS | ironic | no fix listed | UBUNTU-CVE-2025-44021 |
| Ubuntu:25.10 | ironic | no fix listed | UBUNTU-CVE-2025-44021 |
| Ubuntu:26.04:LTS | ironic | no fix listed | UBUNTU-CVE-2025-44021 |
| Ubuntu:26.10 | ironic | no fix listed | UBUNTU-CVE-2025-44021 |
Affected products (as reported)
Weakness: CWE-22 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N