Vulnerability · Published Jun 12, 2025 · Assigned by GitHub_M

CVE-2025-43863vantage6 lacks brute-force protection on change password functionality

Low 1.7

In plain English

A low-severity security flaw in vantage6 from vantage6. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)1.7Low
Exploit odds (30 days)0.5%top 59.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vantage6 is an open source framework built to enable, manage and deploy privacy enhancing technologies like Federated Learning and Multi-Party Computation. If attacker gets access to an authenticated session, they can try to brute-force the user password by using the change password functionality: they can call that route infinitely which will return the message that password is wrong until it is correct. This vulnerability is fixed in 4.11.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvantage64.11.0GHSA-j6g5-p62x-58hw
PyPIvantage64.11.0PYSEC-2025-220

Affected products (as reported)

VendorProductVersions
vantage6 vantage6 < 4.11.0

Weakness: CWE-307 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:U

References