Vulnerability · Published Apr 24, 2025 · Assigned by GitHub_M
CVE-2025-43859h11 accepts some malformed Chunked-Encoding bodies
Critical 9.1
In plain English
A critical-severity security flaw in h11 from python-hyper. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
h11 is a Python implementation of HTTP/1.1. Prior to version 0.16.0, a leniency in h11's parsing of line terminators in chunked-coding message bodies can lead to request smuggling vulnerabilities under certain conditions. This issue has been patched in version 0.16.0. Since exploitation requires the combination of buggy h11 with a buggy (reverse) proxy, fixing either component is sufficient to mitigate this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | python-h11 | 0.14.0-1.1~deb12u1 | DEBIAN-CVE-2025-43859 |
| Debian:13 | python-h11 | 0.14.0-1.1 | DEBIAN-CVE-2025-43859 |
| Debian:14 | python-h11 | 0.14.0-1.1 | DEBIAN-CVE-2025-43859 |
| PyPI | h11 | 0.16.0 | GHSA-vqfr-h8mv-ghfj |
| PyPI | h11 | 0.16.0 | PYSEC-2026-348 |
| Ubuntu:24.04:LTS | python-h11 | 0.14.0-1ubuntu0.24.04.1 | USN-7503-1 |
| Ubuntu:24.04:LTS | python-h11 | 0.14.0-1ubuntu0.24.04.1 | UBUNTU-CVE-2025-43859 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| python-hyper | h11 | < 0.16.0 |
Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N