Vulnerability · Published Dec 17, 2025 · Assigned by apple

CVE-2025-43501

Medium 4.3

In plain English

A medium-severity buffer overflow in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.8%top 44.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A buffer overflow issue was addressed with improved memory handling. This issue is fixed in Safari 26.2, iOS 18.7.3 and iPadOS 18.7.3, iOS 26.2 and iPadOS 26.2, macOS Tahoe 26.2, visionOS 26.2. Processing maliciously crafted web content may lead to an unexpected process crash.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.50.4-1.el8_10ALSA-2025:23663
AlmaLinux:9webkit2gtk32.50.4-1.el9_7ALSA-2025:23700
AlmaLinux:8webkit2gtk3-devel2.50.4-1.el8_10ALSA-2025:23663
AlmaLinux:9webkit2gtk3-devel2.50.4-1.el9_7ALSA-2025:23700
AlmaLinux:8webkit2gtk3-jsc2.50.4-1.el8_10ALSA-2025:23663
AlmaLinux:9webkit2gtk3-jsc2.50.4-1.el9_7ALSA-2025:23700
AlmaLinux:8webkit2gtk3-jsc-devel2.50.4-1.el8_10ALSA-2025:23663
AlmaLinux:9webkit2gtk3-jsc-devel2.50.4-1.el9_7ALSA-2025:23700
Debian:12webkit2gtk2.50.4-1~deb12u1DEBIAN-CVE-2025-43501
Debian:12webkit2gtk2.50.4-1~deb12u1DSA-6083-1
Debian:13webkit2gtk2.50.4-1~deb13u1DSA-6083-1
Debian:13webkit2gtk2.50.4-1~deb13u1DEBIAN-CVE-2025-43501
Debian:14webkit2gtk2.50.4-1DEBIAN-CVE-2025-43501
Debian:12wpewebkitno fix listedDEBIAN-CVE-2025-43501
Debian:13wpewebkitno fix listedDEBIAN-CVE-2025-43501
Debian:14wpewebkit2.50.4-1DEBIAN-CVE-2025-43501
Rocky Linux:8webkit2gtk30:2.50.4-1.el8_10RLSA-2025:23663
Rocky Linux:9webkit2gtk30:2.50.4-1.el9_7RLSA-2025:23700
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-43501
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-43501
Ubuntu:22.04:LTSwebkit2gtk2.50.4-0ubuntu0.22.04.1USN-7957-1
Ubuntu:22.04:LTSwebkit2gtk2.50.4-0ubuntu0.22.04.1UBUNTU-CVE-2025-43501
Ubuntu:24.04:LTSwebkit2gtk2.50.4-0ubuntu0.24.04.1UBUNTU-CVE-2025-43501
Ubuntu:24.04:LTSwebkit2gtk2.50.4-0ubuntu0.24.04.1USN-7957-1
Ubuntu:25.10webkit2gtk2.50.4-0ubuntu0.25.10.1USN-7957-1
Ubuntu:25.10webkit2gtk2.50.4-0ubuntu0.25.10.1UBUNTU-CVE-2025-43501
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2025-43501

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 26.2
Apple iOS and iPadOS 0 – before 18.7.30 – before 26.2
Apple macOS 0 – before 26.2
Apple visionOS 0 – before 26.2

Weakness: CWE-120 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

References