Vulnerability · Published Nov 4, 2025 · Assigned by apple

CVE-2025-43480

High 8.1

In plain English

A high-severity security flaw in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.5%top 57.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The issue was addressed with improved checks. This issue is fixed in Safari 26.1, iOS 26.1 and iPadOS 26.1, macOS Tahoe 26.1, tvOS 26.1, visionOS 26.1, watchOS 26.1. A malicious website may exfiltrate data cross-origin.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.46.3-1.el8_10ALSA-2024:9636
AlmaLinux:8webkit2gtk32.50.3-1.el8_10ALSA-2025:22789
AlmaLinux:9webkit2gtk32.50.3-1.el9_7ALSA-2025:22790
AlmaLinux:8webkit2gtk3-devel2.46.3-1.el8_10ALSA-2024:9636
AlmaLinux:8webkit2gtk3-devel2.50.3-1.el8_10ALSA-2025:22789
AlmaLinux:9webkit2gtk3-devel2.50.3-1.el9_7ALSA-2025:22790
AlmaLinux:8webkit2gtk3-jsc2.50.3-1.el8_10ALSA-2025:22789
AlmaLinux:8webkit2gtk3-jsc2.46.3-1.el8_10ALSA-2024:9636
AlmaLinux:9webkit2gtk3-jsc2.50.3-1.el9_7ALSA-2025:22790
AlmaLinux:8webkit2gtk3-jsc-devel2.50.3-1.el8_10ALSA-2025:22789
AlmaLinux:8webkit2gtk3-jsc-devel2.46.3-1.el8_10ALSA-2024:9636
AlmaLinux:9webkit2gtk3-jsc-devel2.50.3-1.el9_7ALSA-2025:22790
Debian:12webkit2gtk2.46.0-2~deb12u1DSA-5792-1
Debian:12webkit2gtk2.46.0-2~deb12u1DEBIAN-CVE-2025-43480
Debian:13webkit2gtk2.46.0-1DEBIAN-CVE-2025-43480
Debian:14webkit2gtk2.46.0-1DEBIAN-CVE-2025-43480
Debian:12wpewebkitno fix listedDEBIAN-CVE-2025-43480
Debian:13wpewebkit2.46.0-1DEBIAN-CVE-2025-43480
Debian:14wpewebkit2.46.0-1DEBIAN-CVE-2025-43480
Rocky Linux:8webkit2gtk30:2.50.3-1.el8_10RLSA-2025:22789
Rocky Linux:9webkit2gtk30:2.50.3-1.el9_7RLSA-2025:22790
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-43480
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-43480
Ubuntu:22.04:LTSwebkit2gtk2.46.1-0ubuntu0.22.04.3UBUNTU-CVE-2025-43480
Ubuntu:24.04:LTSwebkit2gtk2.46.1-0ubuntu0.24.04.1UBUNTU-CVE-2025-43480
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2025-43480

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 26.1
Apple iOS and iPadOS 0 – before 26.1
Apple macOS 0 – before 26.1
Apple tvOS 0 – before 26.1
Apple visionOS 0 – before 26.1
Apple watchOS 0 – before 26.1

Weakness: CWE-942 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

References