Vulnerability · Published Sep 15, 2025 · Assigned by apple

CVE-2025-43342

Critical 9.8

In plain English

A critical-severity improper input validation in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)0.8%top 44.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A correctness issue was addressed with improved checks. This issue is fixed in Safari 26, iOS 18.7 and iPadOS 18.7, iOS 26 and iPadOS 26, macOS Tahoe 26, tvOS 26, visionOS 26, watchOS 26. Processing maliciously crafted web content may lead to an unexpected process crash.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.50.0-1.el8_10ALSA-2025:17802
AlmaLinux:9webkit2gtk32.50.1-1.el9_7ALSA-2025:20922
AlmaLinux:9webkit2gtk32.50.1-0.el9_6ALSA-2025:18097
AlmaLinux:8webkit2gtk3-devel2.50.0-1.el8_10ALSA-2025:17802
AlmaLinux:9webkit2gtk3-devel2.50.1-1.el9_7ALSA-2025:20922
AlmaLinux:9webkit2gtk3-devel2.50.1-0.el9_6ALSA-2025:18097
AlmaLinux:8webkit2gtk3-jsc2.50.0-1.el8_10ALSA-2025:17802
AlmaLinux:9webkit2gtk3-jsc2.50.1-1.el9_7ALSA-2025:20922
AlmaLinux:9webkit2gtk3-jsc2.50.1-0.el9_6ALSA-2025:18097
AlmaLinux:8webkit2gtk3-jsc-devel2.50.0-1.el8_10ALSA-2025:17802
AlmaLinux:9webkit2gtk3-jsc-devel2.50.1-1.el9_7ALSA-2025:20922
AlmaLinux:9webkit2gtk3-jsc-devel2.50.1-0.el9_6ALSA-2025:18097
Debian:12webkit2gtk2.50.1-1~deb12u1DSA-6042-1
Debian:12webkit2gtk2.50.1-1~deb12u1DEBIAN-CVE-2025-43342
Debian:13webkit2gtk2.50.1-1~deb13u1DSA-6042-1
Debian:13webkit2gtk2.50.1-1~deb13u1DEBIAN-CVE-2025-43342
Debian:14webkit2gtk2.50.0-1DEBIAN-CVE-2025-43342
Debian:12wpewebkitno fix listedDEBIAN-CVE-2025-43342
Debian:13wpewebkitno fix listedDEBIAN-CVE-2025-43342
Debian:14wpewebkit2.50.0-1DEBIAN-CVE-2025-43342
Rocky Linux:8webkit2gtk30:2.50.0-1.el8_10RLSA-2025:17802
Rocky Linux:9webkit2gtk30:2.50.1-1.el9_7RLSA-2025:20922
Rocky Linux:9webkit2gtk30:2.50.1-0.el9_6RLSA-2025:18097
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-43342
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-43342
Ubuntu:22.04:LTSwebkit2gtk2.48.7-0ubuntu0.22.04.2USN-7817-1
Ubuntu:22.04:LTSwebkit2gtk2.48.7-0ubuntu0.22.04.2UBUNTU-CVE-2025-43342
Ubuntu:24.04:LTSwebkit2gtk2.48.7-0ubuntu0.24.04.2USN-7817-1
Ubuntu:24.04:LTSwebkit2gtk2.48.7-0ubuntu0.24.04.2UBUNTU-CVE-2025-43342
Ubuntu:25.10webkit2gtk2.50.0-2ubuntu1UBUNTU-CVE-2025-43342

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 26
Apple iOS and iPadOS 0 – before 18.70 – before 26
Apple macOS 0 – before 26
Apple tvOS 0 – before 26
Apple visionOS 0 – before 26
Apple watchOS 0 – before 26

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References