Vulnerability · Published May 2, 2025 · Assigned by HashiCorp
CVE-2025-4166Vault May Include Sensitive Data in Error Logs When Using the KV v2 Plugin
Medium 4.5
In plain English
A medium-severity security flaw in Vault from HashiCorp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Vault Community and Vault Enterprise Key/Value (kv) Version 2 plugin may unintentionally expose sensitive information in server and audit logs when users submit malformed payloads during secret creation or update operations via the Vault REST API. This vulnerability, identified as CVE-2025-4166, is fixed in Vault Community 1.19.3 and Vault Enterprise 1.19.3, 1.18.9, 1.17.16, 1.16.20.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.22 | openbao | 2.2.2-r0 | ALPINE-CVE-2025-4166 |
| Alpine:v3.23 | openbao | 2.2.2-r0 | ALPINE-CVE-2025-4166 |
| Alpine:v3.24 | openbao | 2.2.2-r0 | ALPINE-CVE-2025-4166 |
| Go | github.com/hashicorp/vault | 1.19.3 | GHSA-gcqf-f89c-68hv |
| Go | github.com/hashicorp/vault | 1.19.3 | GO-2025-3663 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| HashiCorp | Vault | 0.3.0 – before 1.19.2 |
| HashiCorp | Vault Enterprise | 0.10.0 – before 1.19.2 |
Weakness: CWE-209 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N