Vulnerability · Published Feb 13, 2026 · Assigned by apache
CVE-2025-33042Apache Avro Java SDK: Code injection on Java generated code
High 7.3
In plain English
A high-severity code injection in Apache Avro Java SDK from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Avro Java SDK when generating specific records from untrusted Avro schemas. This issue affects Apache Avro Java SDK: all versions through 1.11.4 and version 1.12.0. Users are recommended to upgrade to version 1.12.1 or 1.11.5, which fix the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.avro:avro-compiler | 1.12.1 | GHSA-rp46-r563-jrc7 |
| Maven | org.apache.avro:avro-compiler | 1.11.5 | GHSA-rp46-r563-jrc7 |
| PyPI | avro | 1.11.5 | PYSEC-2026-26 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Avro Java SDK | 0 – through 1.11.41.12.0 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L