Vulnerability · Published Apr 30, 2025 · Assigned by GitHub_M

CVE-2025-32972The lesscss script service allows cache clearing without programming right

Low 2.7

In plain English

A low-severity security flaw in xwiki-platform from xwiki. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)2.7Low
Exploit odds (30 days)0.5%top 55.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

XWiki is a generic wiki platform. In versions starting from 6.1-milestone-1 to before 15.10.12, from 16.0.0-rc-1 to before 16.4.3, and from 16.5.0-rc-1 to before 16.8.0-rc-1, the script API of the LESS compiler in XWiki is incorrectly checking for rights when calling the cache cleaning API, making it possible to clean the cache without having programming right. The only impact of this is a slowdown in XWiki execution as the caches are re-filled. As this vulnerability requires script right to exploit, and script right already allows unlimited execution of scripts, the additional impact due to this vulnerability is low. This issue has been patched in versions 15.10.12, 16.4.3, and 16.8.0-rc-1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.xwiki.platform:xwiki-platform-lesscss-script15.10.12GHSA-rp38-24m3-rx87
Mavenorg.xwiki.platform:xwiki-platform-lesscss-script16.4.3GHSA-rp38-24m3-rx87
Mavenorg.xwiki.platform:xwiki-platform-lesscss-script16.8.0-rc-1GHSA-rp38-24m3-rx87

Affected products (as reported)

VendorProductVersions
xwiki xwiki-platform >= 6.1-milestone-1, < 15.10.12>= 16.0.0-rc-1, < 16.4.3>= 16.5.0-rc-1, < 16.8.0-rc-1

Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L

References