Vulnerability · Published Apr 23, 2025 · Assigned by GitHub_M
CVE-2025-32968org.xwiki.platform:xwiki-platform-oldcore allows SQL injection in short form select requests through the script query API
High 8.6
In plain English
A high-severity SQL injection in xwiki-platform from xwiki. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
XWiki is a generic wiki platform. In versions starting from 1.6-milestone-1 to before 15.10.16, 16.4.6, and 16.10.1, it is possible for a user with SCRIPT right to escape from the HQL execution context and perform a blind SQL injection to execute arbitrary SQL statements on the database backend. Depending on the used database backend, the attacker may be able to not only obtain confidential information such as password hashes from the database, but also execute UPDATE/INSERT/DELETE queries. This issue has been patched in versions 16.10.1, 16.4.6 and 15.10.16. There is no known workaround, other than upgrading XWiki. The protection added to this REST API is the same as the one used to validate complete select queries, making it more consistent. However, while the script API always had this protection for complete queries, it's important to note that it's a very strict protection and some valid, but complex, queries might suddenly require the author to have programming right.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.xwiki.platform:xwiki-platform-oldcore | 15.10.16 | GHSA-g9jj-75mx-wjcx |
| Maven | org.xwiki.platform:xwiki-platform-oldcore | 16.4.6 | GHSA-g9jj-75mx-wjcx |
| Maven | org.xwiki.platform:xwiki-platform-oldcore | 16.10.1 | GHSA-g9jj-75mx-wjcx |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| xwiki | xwiki-platform | >= 1.6-milestone-1, < 15.10.16>= 16.0.0-rc-1, < 16.4.6>= 16.5.0-rc-1, < 16.10.1 |
Weakness: CWE-89 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-g9jj-75mx-wjcx x_refsource_CONFIRM
- https://jira.xwiki.org/browse/XWIKI-22718 x_refsource_MISC