Vulnerability · Published Apr 30, 2025 · Assigned by GitHub_M

CVE-2025-32444vLLM Vulnerable to Remote Code Execution via Mooncake Integration

Critical 10.0

In plain English

A critical-severity unsafe deserialization in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 79% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)1.8%top 21.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.6.5 and prior to 0.8.5, having vLLM integration with mooncake, are vulnerable to remote code execution due to using pickle based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. vLLM instances that do not make use of the mooncake integration are not vulnerable. This issue has been patched in version 0.8.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.8.5GHSA-hj4w-hm2g-p6w5
PyPIvllm0.8.5PYSEC-2025-42

Affected products (as reported)

VendorProductVersions
vllm-project vllm >= 0.6.5, < 0.8.5

Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

References