Vulnerability · Published Apr 18, 2025 · Assigned by GitHub_M

CVE-2025-32442Fastify vulnerable to invalid content-type parsing, which could lead to validation bypass

High 7.5

In plain English

A high-severity security flaw in fastify from fastify. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.7%top 45.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Fastify is a fast and low overhead web framework, for Node.js. In versions 5.0.0 to 5.3.0 as well as version 4.29.0, applications that specify different validation strategies for different content types have a possibility to bypass validation by providing a _slightly altered_ content type such as with different casing or altered whitespacing before `;`. This was patched in v5.3.1, but the initial patch did not cover all problems. This has been fully patched in v5.3.2 and v4.29.1. A workaround involves not specifying individual content types in the schema.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmfastify5.8.5GHSA-247c-9743-5963
npmfastify5.3.2GHSA-mg2h-6x62-wpwc
npmfastify4.29.1GHSA-mg2h-6x62-wpwc

Affected products (as reported)

VendorProductVersions
fastify fastify >= 5.0.0, < 5.3.2= 4.29.0

Weakness: CWE-1287 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References