Vulnerability · Published Apr 14, 2025 · Assigned by GitHub_M

CVE-2025-32428Jupyter Remote Desktop Proxy makes TigerVNC accessible via the network and not just via a UNIX socket as intended

Critical 9.0

In plain English

A critical-severity security flaw in jupyter-remote-desktop-proxy from jupyterhub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.0Critical
Exploit odds (30 days)0.9%top 39.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Jupyter Remote Desktop Proxy allows you to run a Linux Desktop on a JupyterHub. jupyter-remote-desktop-proxy was meant to rely on UNIX sockets readable only by the current user since version 3.0.0, but when used with TigerVNC, the VNC server started by jupyter-remote-desktop-proxy were still accessible via the network. This vulnerability does not affect users having TurboVNC as the vncserver executable. This issue is fixed in 3.0.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIjupyter-remote-desktop-proxy3.0.1GHSA-vrq4-9hc3-cgp7
PyPIjupyter-remote-desktop-proxy3.0.1PYSEC-2026-365

Affected products (as reported)

VendorProductVersions
jupyterhub jupyter-remote-desktop-proxy >= 3.0.0, < 3.0.1

Weakness: CWE-668 · Vector: CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

References