Vulnerability · Published Apr 10, 2025 · Assigned by GitHub_M
CVE-2025-32027Yii does not prevent XSS in scenarios where fallback error renderer is used
Medium 6.1
In plain English
A medium-severity cross-site scripting in yii from yiisoft. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.2%top 83.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | yiisoft/yii | 1.1.31 | GHSA-7r2v-8wxr-3ch5 |
Affected products (as reported)
Weakness: CWE-79, CWE-80 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
References
- https://github.com/yiisoft/yii/security/advisories/GHSA-7r2v-8wxr-3ch5 x_refsource_CONFIRM
- https://github.com/yiisoft/yii/commit/d386d737861c9014269b7ed8c36c65eadb387368 x_refsource_MISC