Vulnerability · Published Apr 9, 2025 · Assigned by apache

CVE-2025-31672Apache POI: parsing OOXML based files (xlsx, docx, etc.), poi-ooxml could read unexpected data if underlying zip has duplicate zip entry names

Medium 5.3

In plain English

A medium-severity improper input validation in Apache POI from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)1.4%top 27.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Input Validation vulnerability in Apache POI. The issue affects the parsing of OOXML format files like xlsx, docx and pptx. These file formats are basically zip files and it is possible for malicious users to add zip entries with duplicate names (including the path) in the zip. In this case, products reading the affected file could read different data because 1 of the zip entries with the duplicate name is selected over another but different products may choose a different zip entry. This issue affects Apache POI poi-ooxml before 5.4.0. poi-ooxml 5.4.0 has a check that throws an exception if zip entries with duplicate file names are found in the input file. Users are recommended to upgrade to version poi-ooxml 5.4.0, which fixes the issue. Please read https://poi.apache.org/security.html for recommendations about how to use the POI libraries securely.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12libapache-poi-javano fix listedDEBIAN-CVE-2025-31672
Debian:13libapache-poi-javano fix listedDEBIAN-CVE-2025-31672
Debian:14libapache-poi-javano fix listedDEBIAN-CVE-2025-31672
Mavenorg.apache.poi:poi-ooxml5.4.0GHSA-gmg8-593g-7mv3
Ubuntu:22.04:LTSlibapache-poi-javano fix listedUBUNTU-CVE-2025-31672
Ubuntu:24.04:LTSlibapache-poi-javano fix listedUBUNTU-CVE-2025-31672
Ubuntu:25.10libapache-poi-javano fix listedUBUNTU-CVE-2025-31672
Ubuntu:26.04:LTSlibapache-poi-javano fix listedUBUNTU-CVE-2025-31672
Ubuntu:26.10libapache-poi-javano fix listedUBUNTU-CVE-2025-31672

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache POI 0 – before 5.4.0

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

References