Vulnerability · Published Apr 28, 2025 · Assigned by apache
CVE-2025-31650Apache Tomcat: DoS via malformed HTTP/2 PRIORITY_UPDATE frame
High 7.5
In plain English
A high-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 61.3% (higher than 99.2% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service. This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | tomcat | 1:9.0.87-1.el8_10.4 | ALSA-2025:11333 |
| AlmaLinux:9 | tomcat | 1:9.0.87-3.el9_6.1 | ALSA-2025:11335 |
| AlmaLinux:8 | tomcat-admin-webapps | 1:9.0.87-1.el8_10.4 | ALSA-2025:11333 |
| AlmaLinux:9 | tomcat-admin-webapps | 1:9.0.87-3.el9_6.1 | ALSA-2025:11335 |
| AlmaLinux:8 | tomcat-docs-webapp | 1:9.0.87-1.el8_10.4 | ALSA-2025:11333 |
| AlmaLinux:9 | tomcat-docs-webapp | 1:9.0.87-3.el9_6.1 | ALSA-2025:11335 |
| AlmaLinux:8 | tomcat-el-3.0-api | 1:9.0.87-1.el8_10.4 | ALSA-2025:11333 |
| AlmaLinux:9 | tomcat-el-3.0-api | 1:9.0.87-3.el9_6.1 | ALSA-2025:11335 |
| AlmaLinux:8 | tomcat-jsp-2.3-api | 1:9.0.87-1.el8_10.4 | ALSA-2025:11333 |
| AlmaLinux:9 | tomcat-jsp-2.3-api | 1:9.0.87-3.el9_6.1 | ALSA-2025:11335 |
| AlmaLinux:8 | tomcat-lib | 1:9.0.87-1.el8_10.4 | ALSA-2025:11333 |
| AlmaLinux:9 | tomcat-lib | 1:9.0.87-3.el9_6.1 | ALSA-2025:11335 |
| AlmaLinux:8 | tomcat-servlet-4.0-api | 1:9.0.87-1.el8_10.4 | ALSA-2025:11333 |
| AlmaLinux:9 | tomcat-servlet-4.0-api | 1:9.0.87-3.el9_6.1 | ALSA-2025:11335 |
| AlmaLinux:8 | tomcat-webapps | 1:9.0.87-1.el8_10.4 | ALSA-2025:11333 |
| AlmaLinux:9 | tomcat-webapps | 1:9.0.87-3.el9_6.1 | ALSA-2025:11335 |
| AlmaLinux:10 | tomcat9 | 1:9.0.87-5.el10_0.1 | ALSA-2025:11332 |
| AlmaLinux:10 | tomcat9-admin-webapps | 1:9.0.87-5.el10_0.1 | ALSA-2025:11332 |
| AlmaLinux:10 | tomcat9-docs-webapp | 1:9.0.87-5.el10_0.1 | ALSA-2025:11332 |
| AlmaLinux:10 | tomcat9-el-3.0-api | 1:9.0.87-5.el10_0.1 | ALSA-2025:11332 |
| AlmaLinux:10 | tomcat9-jsp-2.3-api | 1:9.0.87-5.el10_0.1 | ALSA-2025:11332 |
| AlmaLinux:10 | tomcat9-lib | 1:9.0.87-5.el10_0.1 | ALSA-2025:11332 |
| AlmaLinux:10 | tomcat9-servlet-4.0-api | 1:9.0.87-5.el10_0.1 | ALSA-2025:11332 |
| AlmaLinux:10 | tomcat9-webapps | 1:9.0.87-5.el10_0.1 | ALSA-2025:11332 |
| Debian:12 | tomcat10 | 10.1.40-1 | DEBIAN-CVE-2025-31650 |
| Debian:13 | tomcat10 | 10.1.40-1 | DEBIAN-CVE-2025-31650 |
| Debian:14 | tomcat10 | 10.1.40-1 | DEBIAN-CVE-2025-31650 |
| Debian:13 | tomcat11 | 11.0.6-1 | DEBIAN-CVE-2025-31650 |
| Debian:14 | tomcat11 | 11.0.6-1 | DEBIAN-CVE-2025-31650 |
| Debian:12 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-31650 |
| Debian:13 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-31650 |
| Debian:14 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-31650 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 9.0.104 | GHSA-3p2h-wqq4-wf4h |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 11.0.6 | GHSA-3p2h-wqq4-wf4h |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | no fix listed | GHSA-3p2h-wqq4-wf4h |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 10.1.40 | GHSA-3p2h-wqq4-wf4h |
| Maven | org.apache.tomcat:tomcat-coyote | 11.0.6 | GHSA-3p2h-wqq4-wf4h |
| Maven | org.apache.tomcat:tomcat-coyote | no fix listed | GHSA-3p2h-wqq4-wf4h |
| Maven | org.apache.tomcat:tomcat-coyote | 10.1.40 | GHSA-3p2h-wqq4-wf4h |
| Maven | org.apache.tomcat:tomcat-coyote | 9.0.104 | GHSA-3p2h-wqq4-wf4h |
| Rocky Linux:8 | tomcat | 1:9.0.87-1.el8_10.4 | RLSA-2025:11333 |
| Rocky Linux:9 | tomcat | 1:9.0.87-3.el9_6.1 | RLSA-2025:11335 |
| Rocky Linux:10 | tomcat9 | 1:9.0.87-5.el10_0.1 | RLSA-2025:11332 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Tomcat | 9.0.76 – through 9.0.10210.1.10 – through 10.1.3911.0.0-M2 – through 11.0.58.5.90 – through 8.5.100 |
Weakness: CWE-459 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H